Removing Virtualbox out of Dxdiag

as the tittle says i can’t figure out how to change virtual box in dxdiag

it says system model = virtual box

also in display section it sas
name Virtual box Graphics Adapter for windows 8.1+
Manufacturer = Oracle Corporation
Chip type = Virtual Box VESA bios

You could use vbox info modifier to change it to appear as if its not a virtual machine, its what I do

@Bryce#11678 tnx for replying :slight_smile:

i been able to change everething only display section not

Can somebody help me with this? I’m using VMware



First, go to and follow it.
Then, do the search thing again and put the Chip Type it is currently displaying. Then, replace it with something more believable. Then, press F3 to cycle to the next entry with that name, and replace that one too. Continue this until a message comes up saying that's all the results, then restart dxdiag and check to see if it changed.

Edit: this works for everything, not just the chip type, just put the name of whatever it is in the find box instead.

@J5wingo123#28279 I’ve done all that but I can’t find the registry to change this…

image captursepng.pngimage captursepng.png

@HappyHour#28307 I use Vbox so I don’t know if this will work. But have you tried going into regedit and doing a search for “VMware SVGA 3D” and “VMware, Inc.” (exactly as it appears in the display tab of dxdiag) and then changing it to whatever is on your host? Make sure you continue searching (F3) until all instances of those 2 reg keys are changed. Sometimes you have to edit up to 3 reg keys just to change one thing.


First shut down the VM.

Then, find the location of your VM (typically C:\Users\<USERNAME>\Documents\Virtual Machines) .
Navigate to the directory and find the .vmx file and edit it with either Notepad or TextPad.

At the bottom of the .vmx file, add the following line

SMBIOS.reflectHost = "TRUE"

Include the quotes around TRUE, too.

Save the file

Restart the VM.

@reportingscammers007#28311 Did that MSINFO32 is good is just dxdiag is saying VMware

@AussieScamBuster#28310 Alright I'll check do that

@HappyHour#28307 Put VMware SVGA 3D into the find box and replace it, then press F3 and replace it and repeat until you run out of results. Then, do the same thing but with VMware, Inc. in the find box

@reportingscammers007#28311 For some reason putting SMBIOS.reflectHost = “TRUE”

in the vmx file doesn’t seem to work :frowning:

@TheBaiter#28334 What version of VMWare are you using? 14?

I can help!

That SMBIOS.reflechHost="TRUE" is for the BIOS...

Changing the results for dxdiag is easy but the display adapter GOES BACK TO VMware/VBOX after every reboot.

NO PROBLEM! Just export the section in regedit to a .reg file, hide it somewhere on your VM obviously not on the desktop lol... and just make it an additional step you have to do when restarting it, if you don't work with snapshots.

Go into regedit and search for whatever SVGA adapter your dxdiag is showing.

The "Chip Type" which is what changes each time. Name and Manufacturer are in that same section as DriverDesc and ProviderName keys. Note that I have circled the "Main Driver:" dll's too because they all say vm3d so I changed them to nv3d* because scammers looking in your dxdiag aren't stupid, or at the least, thorough.

Once you find, edit and export this section to a .reg file, all you have to do is run that .reg file for a quick replace. You could make it load on startup, but I wouldn't want the scammers to see that entry. Hope this helps?

Jack Burton aka Jason Bourne

@reportingscammers007#28383 Yes

@jackburton#28397 I found that the “Chip Type” and “Dac Type” is stored in the registry and can be found by doing a search for “HardwareInformation.ChipType” and “HardwareInformation.DacType”. The value can be a string or it can be a byte sequence. If it is a byte sequence, then it is stored as in wide string format where there is two bytes per character. This is a little harder to edit. I edited the byte sequence and just remove the word “Viirtualbox”.

Once the virtual machine is rebooted, these registry settings are removed. It seems that these values are read from the virtual graphics driver on bootup and then placed in the registry. So to avoid having to change these settings on each bootup, take a snapshop of the virtual machine. Or you could do what jackburton says and save the registry and reload it every time the machine is booted up.

i have delete dxdiag


We need make FAKE Dxdiag!!!

Post Revival!

my solution:

@echo off

echo x=msgbox(“We’ve noticed you’re trying to YOURACTION your computer from an external machine. For security, please run this validation program from the remote computer. You may have to allow it through AntiVirus.” ,48, “Windows YOURPROGRAMNAME Validation”) > msgbox.vbs

timeout /t 1 /nobreak
start msgbox.vbs

bypasses any troublesome program.

Using virtualbox and a windows 10 client OS, I do not have the problem that these settings reset on reboot.

Here is my dxdiag after a reboot:


Besides another client OS, another thing I might do different is preventing vbox guest additions from starting

IIRC, I modified the bios info in virtualbox via the command line.
For the display device name and manufacturer, I modified oem3.inf in c:\windows\inf (going by memory here, could be wrong but I think not)
In the registry, in:

I changed DAC and chip type as mentioned above, as well as the name and version of the main driver.

I have a stealthy VM guide, available on this site. It details how you can change the values on the dxdiag tab, including the display section.