Editing Bios Version/Date On VM

Hello. I was recently trying to scambait a scammer when he ran the msinfo command and noticed that VMware was in the name of the Bios Version/Date. Is there anyway to change this? Screen shot https://drive.google.com/file/d/1Wgb5VHzC-Hn7iHc_huvvUYYktgyMRaKQ/view?usp=sharing

@DriedSponge your vm has to be stopped/paused (atleast not running)

  1. locate the *.vmx file of your virtual machine,
  2. open it with notepad and add at the bottom:
    SMBIOS.reflectHost = “TRUE”
    SMBIOS.noOEMStrings = “TRUE”
    smbios.addHostVendor = “TRUE”
  3. save and reboot vm and check msinfo32

Additionally there’s more stuff you can hide, Jim Browning did an awesome tutorial: [Tutorial] How to make a stealthy Virtual Machine - YouTube

1 Like

@NeeP Ok thanks man

@DriedSponge you’re welcome :slight_smile:

@NeeP I made the changes to the vmx file but the Bios Version/Date still has VMware in the name. Any solution?

@DriedSponge You can download a fake msinfo32 and replace it. Unfortunately my VM is fried and I can’t find the link of that. You gotta search for it. The website also has steps to replace the msinfo32 with the fake one.

Ok I’ll search for it, thanks!

For anyone else wondering, I found the solution. When setting up the VM, make sure you select BIOS and not UEFI.

The second 2 command lines nooems and addhost are not working for me. I’m running a win 10 machine I edited the VMX wit reclecthost = true that worked fine but the other 2 just crashed the entire thing basically had to delete the lines in order to get that working again.

Welcome! @Nikad1

Maybe you wrote it in wrong formatting? I noticed that my post above was faulty in terms of formatting. Check it now again. Add each command in a new line, just as shown above. There’s no reason why it would break the VM.

Yea NeeP I did that edit it just the way as you had written down and now the VMware doesn’t even recognize a VM even being there for some reason its not able to locate anything luckily I took a screen shot.

This is how it looks like in my .vmx file, definitely working:

If your VM isn’t shonw, just open it again and then navigate to the folder and select the .vmx file again:

it has showed again everything else is matching my regular desktop. How ever the only thing that is NOT changing at the moment is the Bios Version Bios Date it still just says VM ware. That is the only thing that is giving my VM away that its a virtual machine at the moment and that’s what I’m trying to get rid of. I was able to find the VM again with the added lines of code.