BobRTC + Bait Army not working?

Hey all,

I was going to start getting back into scambaiting, but when I try to sign up with BaitArmy, it tells me I didn’t pass the with the message “Account not accepted” and a number of ‘reasons’ below. I’ve tried VPN’ing to different locations and used different emails. I’m wondering if it’s because I’m on a Mac? I’m going to try it on one of my OfficeVMs now.

Has anyone been experiencing this?

1 Like

they migrated for the nth time and deleted all accounts that did not migrate in time, so your account was deleted

1 Like

I have a google voice number I can call with, but the interface was great. Is there anyway back onto the platform? I have no idea why I can’t sign up. None of the things listed apply to me.

I think they’re blocking VPNs now, so try turning that off.

Why do they keep migrating to a new login system and delete accounts?

At first, when it began using Discord for login it worked great, but lately all the login problems made me think this website is not worth the hassle and i’m better off calling numbers using a voip app.

Ya, I’m resorting to google voice… been trying to figure out the best method to change my voice without too much processing delay.